Note: The other languages of the website are Google-translated. Back to English

如何在Excel中快速排行联赛表?

众所周知,在联盟中,一支球队的排名不仅取决于一个因素,还取决于三个因素:总分,目标差和目标得分。 在本教程中,我将介绍如何在Excel中快速对排名表进行排名。

排名联赛表


箭头蓝色右气泡 排名联赛表

例如,有一个如下所示的联赛表,现在按照步骤一步一步对球队进行排名。
doc排名联赛表1

1.首先,计算每个团队的总积分。 当获胜者获得2分时,请选择一个单元格IXNUMX,然后键入以下公式 = C2 * 3 + D2 (C2包含获胜次数,D2是平局),将填充手柄向下拖动到需要应用此公式的单元格上。 看截图:
doc排名联赛表2

2.现在对总分进行排名。 选择单元格J2,键入此公式 = COUNTIF($ I $ 2:$ I $ 21,“>”&I2)+1 (I2是列表中包含总点的第一个单元格,I2:I21是总点的列表),将手柄向下拖动到所需的单元格。
doc排名联赛表3

3.然后排列目标差。 选择单元格K2,然后键入此公式 =(COUNTIF($H$2:$H$21,">"&H2)+1)/100 (H2是包含目标差的第一个单元格,H2:H21是目标差的列表),向下拖动填充手柄以填充单元格。
doc排名联赛表4

4.在此步骤中对得分目标进行排名。 选择单元格L2,然后键入公式 =(COUNTIF($F$2:$F$21,">"&F2)+1)/1000 (F2是目标得分,F2:F21是目标得分列表),将填充手柄向下拖动到单元格。
doc排名联赛表5

5.现在将总积分排名,目标差排名和目标得分排名加在一起。 单元格M2,使用此公式 = J2 + K2 + L2 (J2,K2,L2是总积分等级,目标差等级和目标得分等级),向下拖动填充手柄以将该公式填充到单元格中。
doc排名联赛表6

6.最后,您可以获得联盟球队的排名。 选择要放置排名的单元格,例如N2,键入此公式 = COUNTIF($ M $ 2:$ M $ 21,“ <”&M2)+1,(M2是总积分排名,目标差排名和目标得分排名之和的列表中的第一个单元格,而M2:M21是总积分排名,目标差排名和目标得分排名的总和的列表),拖动填充处理下来以填写公式。
doc排名联赛表7

无需公式即可轻松地将数字向上或向下取整,甚至在Excel中取整

众所周知,有些公式可以四舍五入,但是您不想使用公式四舍五入,因此Kutools for Excel的Round实用程序可以帮到您。 点击查看 30 天免费试用!
文档轮
Kutools for Excel:拥有 300 多个方便的 Excel 插件,免费试用,无限制 30 天。
 

最佳办公效率工具

Kutools for Excel解决了您的大多数问题,并使您的生产率提高了80%

  • 重用: 快速插入 复杂的公式,图表 以及您以前使用过的任何东西; 加密单元 带密码 创建邮件列表 并发送电子邮件...
  • 超级公式栏 (轻松编辑多行文本和公式); 阅读版式 (轻松读取和编辑大量单元格); 粘贴到过滤范围...
  • 合并单元格/行/列 不会丢失数据; 拆分单元格内容; 合并重复的行/列...防止细胞重复; 比较范围...
  • 选择重复或唯一 行; 选择空白行 (所有单元格都是空的); 超级查找和模糊查找 在许多工作簿中; 随机选择...
  • 确切的副本 多个单元格,无需更改公式参考; 自动创建参考 到多张纸; 插入项目符号,复选框等...
  • 提取文字,添加文本,按位置删除, 删除空间; 创建和打印分页小计; 在单元格内容和注释之间转换...
  • 超级滤镜 (将过滤方案保存并应用于其他工作表); 高级排序 按月/周/日,频率及更多; 特殊过滤器 用粗体,斜体...
  • 结合工作簿和工作表; 根据关键列合并表; 将数据分割成多个工作表; 批量转换xls,xlsx和PDF...
  • 超过300种强大功能. 支持 Office / Excel 2007-2021 和 365。支持所有语言。 在您的企业或组织中轻松部署。 完整功能 30 天免费试用。 60 天退款保证。
kte选项卡201905

Office选项卡为Office带来了选项卡式界面,使您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
officetab底部
按评论排序
注释 (4)
还没有评分。 成为第一位评论!
该评论由网站上的主持人最小化
当你在访问中这样做时它更可爱
该评论由网站上的主持人最小化
=EĞERSAY($F$3:$F$6, ">"&F3)+1)/1000 kodlar tutmuyor  
该评论由网站上的主持人最小化
Jag håller på och ska anordna ett VM 提示。 Får dock ett 问题 när jag ska rangordna tabellen。

Jag har gjort alla steg enligt ovan。

1. Innan ngn match är spelad har alla 排名 1 och då står lag 2-4 som #SAKNAS!。

2. När två lag hamnar på samma 排名 där lag 1 vinner med 3-1 och lag 3 vinner med 4-3。 Då får de sammarankingpoäng och den ena står som #SAKNAS!
该评论由网站上的主持人最小化
ANCHE SE RIPETO TOTALMENTE LE FORMULE CHE SI MOSTRANO IN QUESTE PAGINE MI DA' SEMPER UNA RISPOSTA DI ERRORE DELLA FORMULA MI POTRESTI DARE ALTRI SUGGERIMENTI
这里还没有评论
留下你的意见
以访客身份发帖
×
评价此帖子:
0   产品特性
建议地点

关注我们

版权所有 © 2009 - extendoffice.com。 | 版权所有。 供电 ExtendOffice。 | 网站地图
Microsoft和Office徽标是Microsoft Corporation在美国和/或其他国家的商标或注册商标。
受Sectigo SSL保护