Note: The other languages of the website are Google-translated. Back to English

如何根据Excel中的单元格值选中复选框?

您可能知道如何根据复选框更改单元格值。 但是,您知道如何根据Excel中的单元格值自动选中一个复选框吗? 本文将向您展示实现它的方法。

使用公式根据单元格值选中复选框
使用VBA代码根据单元格值选中复选框


使用公式根据单元格值选中复选框

假设您希望当单元格A1中的值等于“测试”时自动选中复选框1。 请执行以下操作。

1.插入复选框(表单控件)后,选择它并通过输入以下内容将其链接到指定的单元格C2 = C2 进入公式栏。

ActiveX控件 复选框,请右键单击它并选择 租房 从右键单击菜单中。 而在 租房 对话框中,输入 连锁细胞链接单元 字段,然后关闭对话框。 看截图:

2.选择内衬单元格(C2),然后输入公式 = IF(A2 =“ Test”,TRUE,FALSE) 进入编辑栏,然后按 输入 键。

备注:在公式中,“ A2”和“测试”是单元格以及您需要根据其自动选中复选框的单元格值。

3.在单元格A1中输入值“测试”时,将自动选中相应的复选框。 看截图:

注意:此公式不区分大小写。


使用VBA代码根据单元格值选中复选框

您可以运行以下VBA代码,以基于Excel中的单元格值选中复选框。

1.右键单击 工作表标签 选中基于单元格值的复选框,然后单击 查看代码 从右键单击菜单中。

2。 在里面 Microsoft Visual Basic应用程序 窗口,请将以下VBA代码复制并粘贴到“代码”窗口中。

VBA代码:根据单元格值选中复选框

Private Sub Worksheet_Change(ByVal Target As Range)
    If Range("A2").Value = "Test" Then
        ActiveSheet.CheckBoxes("Check Box 1").Value = xlOn
    Else
        ActiveSheet.CheckBoxes("Check Box 1").Value = xlOff
    End If
End Sub

备注:在代码中,A2和Test是单元格以及您需要基于其自动选中复选框的单元格值。 复选框1是复选框的名称。

3。 按 其他 + Q 键以关闭“ Microsoft Visual Basic应用程序”窗口。

在单元格A2中输入值“测试”时,将自动选中指定的复选框。

备注:此代码区分大小写。

提示: 如果您要将多个复选框批量插入选定的范围,可以尝试使用 批量插入复选框 实用程序 Kutools for Excel,或将多个选项按钮与 批量插入选项按钮 效用。 此外,您可以一次删除所有复选框 批量删除复选框 实用程序,如下图所示。 你可以去 下载 Kutools for Excel! (30-天免费试用).


相关文章:


最佳办公效率工具

Kutools for Excel解决了您的大多数问题,并使您的生产率提高了80%

  • 重用: 快速插入 复杂的公式,图表 以及您以前使用过的任何东西; 加密单元 带密码 创建邮件列表 并发送电子邮件...
  • 超级公式栏 (轻松编辑多行文本和公式); 阅读版式 (轻松读取和编辑大量单元格); 粘贴到过滤范围...
  • 合并单元格/行/列 不会丢失数据; 拆分单元格内容; 合并重复的行/列...防止细胞重复; 比较范围...
  • 选择重复或唯一 行; 选择空白行 (所有单元格都是空的); 超级查找和模糊查找 在许多工作簿中; 随机选择...
  • 确切的副本 多个单元格,无需更改公式参考; 自动创建参考 到多张纸; 插入项目符号,复选框等...
  • 提取文字,添加文本,按位置删除, 删除空间; 创建和打印分页小计; 在单元格内容和注释之间转换...
  • 超级滤镜 (将过滤方案保存并应用于其他工作表); 高级排序 按月/周/日,频率及更多; 特殊过滤器 用粗体,斜体...
  • 结合工作簿和工作表; 根据关键列合并表; 将数据分割成多个工作表; 批量转换xls,xlsx和PDF...
  • 超过300种强大功能. 支持 Office / Excel 2007-2021 和 365。支持所有语言。 在您的企业或组织中轻松部署。 完整功能 30 天免费试用。 60 天退款保证。
kte选项卡201905

Office选项卡为Office带来了选项卡式界面,使您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
officetab底部
按评论排序
注释 (6)
还没有评分。 成为第一位评论!
该评论由网站上的主持人最小化
我正在尝试使用该复选框在选中或为真时将特定文本显示到另一张纸上,并在未选中或为假时保持空白。
该评论由网站上的主持人最小化
具体来说,如果它是真的,我希望它显示 0700-0800,如果它是假的,则显示一个空白单元格。
该评论由网站上的主持人最小化
Queria saber como fazer isto com mais de um parâmetro de comparação。 Por exemplo: quero que automaticamente minha célula A1 retorne o valor TRUE se e somente se outras três células B1, C1 e D1 estiverem todas com o valor TRUE (caso pelo menos uma delas esteja com o valor FALSE, a célula A1 continuará com o valor错误的)。 Já tentei usar várias fórmulas usando o comando IF, mas êxito。 Por 赞成,você sabe me dizer qual a fórmula certa para conseguir isto? :)
该评论由网站上的主持人最小化
德斯科布里! 阿佩纳斯乌萨尔:

=if(和(B1=true, C1=true, D1=true), true, false)
该评论由网站上的主持人最小化
你好,

我从 Microsoft Office 本身下载了 Excel 模板。
有一列带有复选框和复选标记。
我可以通过输入“1”来激活复选标记,当我这样做时,任务将设置为较浅的颜色。

但我没有激活复选框。 它带有颜色而不是复选标记。 我在公式栏中看到这个 =ALS(G7="";"☐";"⬛") (我认为 ALS 是 IF。我的语言设置为荷兰语)。 我已经在搜索但没有结果。 没有格式控制,我也看不到任何属性。
该评论由网站上的主持人最小化
我可以在谷歌表中这样做吗?
这里还没有评论

关注我们

版权所有 © 2009 - extendoffice.com。 | 版权所有。 供电 ExtendOffice。 | 网站地图
Microsoft和Office徽标是Microsoft Corporation在美国和/或其他国家的商标或注册商标。
受Sectigo SSL保护