Note: The other languages of the website are Google-translated. Back to English
登陆  \/ 
x
or
x
点此注册  \/ 
x

or

如果相邻单元格在Excel中不为空,如何自动编号行?

doc自动编号(如果不为空白)1

在Excel中,我们可以拖动填充手柄以快速轻松地填充一列中的序列号,但是有时,我们需要根据相邻单元格对行进行编号。 例如,如果单元格包含值,则将其编号;如果存在空白单元格,则将序列也保留为空白。 您如何解决此工作,当您在相邻单元格中插入或删除值时,该列可以自动重新编号,如下面的屏幕截图所示?

如果相邻单元格不自动用公式对行进行编号


箭头蓝色右气泡 如果相邻单元格不自动用公式对行进行编号


为了解决这个任务,在这里,我将介绍一个简单的公式,请执行以下操作:

1。 输入以下公式: = IF(B2 <>“”,COUNTA($ B $ 2:B2),“”) 到与数据单元相邻的空白单元中, A2(例如),然后将填充手柄向下拖动到您要应用此公式以根据相邻单元格对列自动编号的单元格,请参见屏幕截图:

备注:在以上公式中, B2 是您要自动编号的单元格。

doc自动编号(如果不为空白)2

2。 现在,当在空白单元格中输入值或删除现有数据时,A列中的序列号将自动重新编号。


最佳办公效率工具

Kutools for Excel解决了您的大多数问题,并使您的生产率提高了80%

  • 重用: 快速插入 复杂的公式,图表 以及您以前使用过的任何东西; 加密单元 带密码 创建邮件列表 并发送电子邮件...
  • 超级公式栏 (轻松编辑多行文本和公式); 阅读版式 (轻松读取和编辑大量单元格); 粘贴到过滤范围...
  • 合并单元格/行/列 不会丢失数据; 拆分单元格内容; 合并重复的行/列...防止细胞重复; 比较范围...
  • 选择重复或唯一 行; 选择空白行 (所有单元格都是空的); 超级查找和模糊查找 在许多工作簿中; 随机选择...
  • 确切的副本 多个单元格,无需更改公式参考; 自动创建参考 到多张纸; 插入项目符号,复选框等...
  • 提取文字,添加文本,按位置删除, 删除空间; 创建和打印分页小计; 在单元格内容和注释之间转换...
  • 超级滤镜 (将过滤方案保存并应用于其他工作表); 高级排序 按月/周/日,频率及更多; 特殊过滤器 用粗体,斜体...
  • 结合工作簿和工作表; 根据关键列合并表; 将数据分割成多个工作表; 批量转换xls,xlsx和PDF...
  • 超过300种强大功能。 支持Office / Excel 2007-2019和365。支持所有语言。 在您的企业或组织中轻松部署。 完整功能30天免费试用。 60天退款保证。
kte选项卡201905

Office选项卡为Office带来了选项卡式界面,使您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
officetab底部
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.
  • To post as a guest, your comment is unpublished.
    Shaiju · 7 months ago
    can we make this in arrayformula

  • To post as a guest, your comment is unpublished.
    Larry · 11 months ago
    Resolved:

    Needed to replace all the commas , with ; then formula worked.

    Thanks.
  • To post as a guest, your comment is unpublished.
    Larry · 11 months ago
    =IF(C13<>"",COUNTA($C$13:C13),"") gives error?

    There is a problem with this formula?
  • To post as a guest, your comment is unpublished.
    SAGAR · 1 years ago
    THANK YOU FOR FORMULA
  • To post as a guest, your comment is unpublished.
    Ajeet · 1 years ago
    thank you so much.
  • To post as a guest, your comment is unpublished.
    Peter · 1 years ago
    Sehr praktische Funktion, allerdings sollte man auf einer deuschsprachigen Seite auch deutschsprachige Excel-Befehle benutzen. Außerdem ist in der Formel ein Fehler. So lautet sie richtig:

    =WENN(B2<>"",ANZAHL2($B$2:B2),"")
  • To post as a guest, your comment is unpublished.
    Pankaj · 1 years ago
    As usual, exactly what I was searching for. Thanks
  • To post as a guest, your comment is unpublished.
    Tim Chen · 2 years ago
    anyway to get skip "" with this formula? i have a list with "" hidden in the cell. thanks
  • To post as a guest, your comment is unpublished.
    Eduardo Alonzo · 2 years ago
    Lol didn't know this formula existed and I did this =IF(B2<>"",(COUNTIF(B:B,"<>"&""))-(COUNTIF(B3:B501,"<>"&"")),"")
    • To post as a guest, your comment is unpublished.
      Jai · 1 years ago
      What is the use of it..