Note: The other languages of the website are Google-translated. Back to English

如何在Excel中以范围内的单位正确地对数字求和?

假设您具有关于每个水果的导入量的一系列数据,如下面的屏幕截图所示,现在您希望将数字与该范围内的单位相加。 通常,公式= SUM(range)不能正确地将数字与单位求和,但是在本教程中,我可以介绍一些好的方法来帮助您快速解决Excel中的此计算问题。

文档总和编号(单位为1)

用公式单位求和

Kutools for Excel的单位总和好主意3

与Kutools for Excel基于相同单位的总和

通过Kutools for Excel合并重复的行并求和对应的数字 好主意3


用公式单位求和

在Excel中,您可以使用公式来处理此任务。

选择一个空白单元格,然后键入此公式 = SUM(SUBSTITUTE(B2:B7,“ kg”,“”)+ 0) 进去,然后按 Shift + Ctrl + 输入 同时获得正确的结果。

文档总和编号(单位为2)
doc箭头
文档总和编号(单位为3)

提示: 在上面的公式中,B2:B7是您要求和的单位的数字,kg是数据范围内的单位,并且所有数字都必须具有相同的单位!


Kutools for Excel的单位总和

如果由于难以记住而不喜欢使用长公式来解决此工作,则可以尝试通过应用 Kutools for Excel's 删除字符 实用程序,然后通过一个简单的公式对其求和。

Kutools for Excel, 与超过 300 方便的功能,使您的工作更加轻松。 

免费安装 Kutools for Excel,请执行以下操作:

1.选择与单位串联的数字,然后单击 库工具 > 文本 > 删除字符。 看截图:

文档总和编号(单位为13)

2.然后检查 非数值 选项仅在 删除字符 对话。 看截图:

文档总和编号(单位为5)

3。 点击 Ok or 使用,并且仅保留所选单元格中的数字。 然后选择一个空白单元格以键入此 = SUM(B2:B7) 计算结果的公式。 看截图:

文档总和编号(单位为6)
doc箭头
文档总和编号(单位为7)

与Kutools for Excel基于相同单位的总和

如果有一个包含水果,数字和不同单位的表格,如下面的屏幕截图所示,如何基于同一单位对数字求和,例如11 Kg + 7 Kg,9磅+11磅。
文档总和编号(单位为8)

免费安装 Kutools for Excel,请执行以下操作:

1.选择一个单元格以放置求和结果,然后单击 库工具 > 公式助手 > 统计 > 基于相同文本的总和.
文档总和编号(单位为8)

2。 在里面 公式助手 对话框,转到 参数输入 部分中,选择包含数字和单位的范围 Range 文本框,然后选择单位文本或基于以下内容输入要求和的单位文本 文本 文本框。 请点击 Ok.
文档总和编号(单位为8)

小技巧:默认情况下,单元格引用在“参数”输入部分中显示为绝对值,如果您需要通过自动填充手柄应用公式,则将其更改为相对值。

然后得到第一个求和结果。
文档总和编号(单位为8)


通过Kutools for Excel合并重复的行并求和对应的数字

但是在某些情况下,如果您的数据范围包含多个单位(如下面的屏幕截图所示),并且您想要将具有相同单位的数字相加,在这种情况下,您也可以使用 高级组合行 功能 Kutools for Excel 解决。

文档总和编号(单位为8)

免费安装 Kutools for Excel,请执行以下操作:

1.选择数据范围,然后单击 库工具 > 合并与拆分 > 高级组合行。 看截图:

文档总和编号(单位为14)

2。 在里面 根据列合并行 对话框中,选择 单位 列并单击 首要的关键 将其标记为主键。 看截图:

文档总和编号(单位为10)

3.然后选择 重量 包含数字的列,然后单击 计算 > 总和。 看截图:

文档总和编号(单位为11)

4。 点击 Ok 现在将相同的单位相加。

文档总和编号(单位为12)


相关文章:


最佳办公效率工具

Kutools for Excel解决了您的大多数问题,并使您的生产率提高了80%

  • 重用: 快速插入 复杂的公式,图表 以及您以前使用过的任何东西; 加密单元 带密码 创建邮件列表 并发送电子邮件...
  • 超级公式栏 (轻松编辑多行文本和公式); 阅读版式 (轻松读取和编辑大量单元格); 粘贴到过滤范围...
  • 合并单元格/行/列 不会丢失数据; 拆分单元格内容; 合并重复的行/列...防止细胞重复; 比较范围...
  • 选择重复或唯一 行; 选择空白行 (所有单元格都是空的); 超级查找和模糊查找 在许多工作簿中; 随机选择...
  • 确切的副本 多个单元格,无需更改公式参考; 自动创建参考 到多张纸; 插入项目符号,复选框等...
  • 提取文字,添加文本,按位置删除, 删除空间; 创建和打印分页小计; 在单元格内容和注释之间转换...
  • 超级滤镜 (将过滤方案保存并应用于其他工作表); 高级排序 按月/周/日,频率及更多; 特殊过滤器 用粗体,斜体...
  • 结合工作簿和工作表; 根据关键列合并表; 将数据分割成多个工作表; 批量转换xls,xlsx和PDF...
  • 超过300种强大功能. 支持 Office / Excel 2007-2021 和 365。支持所有语言。 在您的企业或组织中轻松部署。 完整功能 30 天免费试用。 60 天退款保证。
kte选项卡201905

Office选项卡为Office带来了选项卡式界面,使您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
officetab底部
按评论排序
注释 (1)
还没有评分。 成为第一位评论!
该评论由网站上的主持人最小化
Bonjour dans le tout 1er exercice, ce n'est pas "= SOMME (SUBSTITUT (B2: B7, "kg", "") + 0)" mais "=SOMME(SUBSTITUE(B2:B7;"kg";"" )+0)”。 Il faut mettre des points virgules sinon message d'erreur。 Merci beaucoup pour ce tuto il m'a beaucoup aidé。
这里还没有评论
留下你的意见
以访客身份发帖
×
评价此帖子:
0   产品特性
建议地点

关注我们

版权所有 © 2009 - extendoffice.com。 | 版权所有。 供电 ExtendOffice。 | 网站地图
Microsoft和Office徽标是Microsoft Corporation在美国和/或其他国家的商标或注册商标。
受Sectigo SSL保护