跳到主要内容

如何在Excel中以范围内的单位正确地对数字求和?

作者:孙 最后修改时间:2021-01-26

假设您具有关于每个水果的导入量的一系列数据,如下面的屏幕截图所示,现在您希望将数字与该范围内的单位相加。 通常,公式= SUM(range)不能正确地将数字与单位求和,但是在本教程中,我可以介绍一些好的方法来帮助您快速解决Excel中的此计算问题。

文档总和编号(单位为1)

用公式单位求和

Kutools for Excel 将数字与单位相加好主意3

使用 Kutools for Excel 根据相同单位求和数字

通过 Kutools for Excel 合并重复行并对相应数字求和 好主意3


用公式单位求和

在Excel中,您可以使用公式来处理此任务。

选择一个空白单元格,然后键入此公式 = SUM(SUBSTITUTE(B2:B7,“ kg”,“”)+ 0) 进去,然后按 Shift + Ctrl + 输入 同时获得正确的结果。

文档总和编号(单位为2)
doc箭头
文档总和编号(单位为3)

提示: 在上面的公式中,B2:B7是您要求和的单位的数字,kg是数据范围内的单位,并且所有数字都必须具有相同的单位!


Kutools for Excel 将数字与单位相加

如果由于难以记住而不喜欢使用长公式来解决此工作,则可以尝试通过应用 Excel 的 Kutools's 删除字符 实用程序,然后通过一个简单的公式对其求和。

Kutools for Excel, 与超过 300 方便的功能,使您的工作更加轻松。 

免费安装 Kutools for Excel,请执行以下操作:

1.选择与单位串联的数字,然后单击 库工具 > 文本 > 删除字符。 看截图:

文档总和编号(单位为13)

2.然后检查 非数值 选项仅在 删除字符 对话。 看截图:

文档总和编号(单位为5)

3。 点击 Ok or 申请,并且仅保留所选单元格中的数字。 然后选择一个空白单元格以键入此 = SUM(B2:B7) 计算结果的公式。 看截图:

文档总和编号(单位为6)
doc箭头
文档总和编号(单位为7)

使用 Kutools for Excel 根据相同单位求和数字

如果有一个包含水果,数字和不同单位的表格,如下面的屏幕截图所示,如何基于同一单位对数字求和,例如11 Kg + 7 Kg,9磅+11磅。
文档总和编号(单位为8)

免费安装 Kutools for Excel,请执行以下操作:

1.选择一个单元格以放置求和结果,然后单击 库工具 > 公式助手 > 统计 > 基于相同文本的总和.
文档总和编号(单位为8)

2.在 公式助手 对话框,转到 参数输入 部分中,选择包含数字和单位的范围 范围 文本框,然后选择单位文本或基于以下内容输入要求和的单位文本 文本 文本框。 请点击 Ok.
文档总和编号(单位为8)

Tips::默认情况下,单元格引用在“参数”输入部分中显示为绝对值,如果您需要通过自动填充手柄应用公式,则将其更改为相对值。

然后得到第一个求和结果。
文档总和编号(单位为8)


通过 Kutools for Excel 合并重复行并对相应数字求和

但是在某些情况下,如果您的数据范围包含多个单位(如下面的屏幕截图所示),并且您想要将具有相同单位的数字相加,在这种情况下,您也可以使用 高级组合行 功能 Kutools for Excel 解决。

文档总和编号(单位为8)

免费安装 Kutools for Excel,请执行以下操作:

1.选择数据范围,然后单击 库工具 > 合并与拆分 > 高级组合行。 看截图:

文档总和编号(单位为14)

2.在 根据列合并行 对话框中,选择 单位 列并单击 首要的关键 将其标记为主键。 看截图:

文档总和编号(单位为10)

3.然后选择 重量 包含数字的列,然后单击 计算 > 总和。 看截图:

文档总和编号(单位为11)

4。 点击 Ok 现在将相同的单位相加。

文档总和编号(单位为12)


相关文章:

最佳办公生产力工具

🤖 Kutools 人工智能助手:基于以下内容彻底改变数据分析: 智能执行   |  生成代码  |  创建自定义公式  |  分析数据并生成图表  |  调用 Kutools 函数...
热门特色: 查找、突出显示或识别重复项   |  删除空白行   |  合并列或单元格而不丢失数据   |   不使用公式进行四舍五入 ...
超级查询: 多条件VLookup    多值VLookup  |   跨多个工作表的 VLookup   |   模糊查询 ....
高级下拉列表: 快速创建下拉列表   |  依赖下拉列表   |  多选下拉列表 ....
列管理器: 添加特定数量的列  |  移动列  |  切换隐藏列的可见性状态  |  比较范围和列 ...
特色功能: 网格焦点   |  设计图   |   大方程式酒吧    工作簿和工作表管理器   |  资源库 (自动文本)   |  日期选择器   |  合并工作表   |  加密/解密单元格    按列表发送电子邮件   |  超级筛选   |   特殊过滤器 (过滤粗体/斜体/删除线...)...
前 15 个工具集12 文本 工具 (添加文本, 删除字符,...)   |   50+ 图表 类型 (甘特图,...)   |   40+ 实用 公式 (根据生日计算年龄,...)   |   19 插入 工具 (插入二维码, 从路径插入图片,...)   |   12 转化 工具 (小写金额转大写, 货币兑换,...)   |   7 合并与拆分 工具 (高级组合行, 分裂细胞,...)   |   ... 和更多

使用 Kutools for Excel 增强您的 Excel 技能,体验前所未有的效率。 Kutools for Excel 提供了 300 多种高级功能来提高生产力并节省时间。  单击此处获取您最需要的功能...

描述


Office Tab 为 Office 带来选项卡式界面,让您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
Comments (1)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
Bonjour dans le tout 1er exercice, ce n'est pas "= SOMME (SUBSTITUT (B2: B7, "kg", "") + 0)" mais "=SOMME(SUBSTITUE(B2:B7;"kg";"")+0)". Il faut mettre des points virgules sinon message d'erreur. Merci beaucoup pour ce tuto il m'a beaucoup aidé.
There are no comments posted here yet
Leave your comments
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations