跳到主要内容

如何在Excel中计算具有非零值的单元格数量?

为了计算Excel中具有非零值的单元格总数,这里我们将向您展示两种方法。 请浏览以获取更多详细信息。

用公式计算非零值的像元数
使用 Kutools for Excel 计算具有非零值的单元格数量


用公式计算非零值的像元数

假设您有一系列数据,如下图所示。 要计算具有非零值的像元数,请执行以下操作。

1.选择一个空白单元格以查找计数结果(此处选择单元格H1)。 复制并粘贴公式 = COUNTIF(A1:E8,“ <> 0”)配方栏,然后按 输入 键。 看截图:

2.然后,对选定范围的非零值总数进行计数并显示在单元格H1中。

:

1.使用上面的公式,您可以计算包括空白单元格在内的非零单元格。 如果要同时忽略零单元格和空白单元格,请应用以下公式: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"),然后按 输入 获得结果的关键,请参见屏幕截图:

2.使用上述公式,可以通过更改公式中的单元格引用来计算Excel中行,列或范围中具有非零值的单元格总数。


使用 Kutools for Excel 计算具有非零值的单元格数量

除了公式, 选择特定的单元格 实用程序 Kutools for Excel 可以帮助您快速计算Excel中具有非零值的单元格数量。

申请前 Kutools for Excel首先下载并安装.

1.选择要计算非零像元数的范围。 然后点击 库工具 > 选择 > 选择特定的单元格。 看截图:

2.在弹出 选择特定的单元格 对话框中选择 手机 ,在 选择类型 部分,指定 不相等 ,在 特定类型 下拉列表,然后输入数字 0 放入空白框中。 最后点击 OK 按钮。 看截图:

3.然后弹出一个对话框,告诉您在选定范围内存在多少个非零值单元格。 并且它已经直接排除了空白单元格。 点击 OK 按钮,将立即选择这些单元格。

  如果您想免费试用(30天)此实用程序, 请点击下载,然后按照上述步骤进行操作。

最佳办公生产力工具

热门特色: 查找、突出显示或识别重复项   |  删除空白行   |  合并列或单元格而不丢失数据   |   不使用公式进行四舍五入 ...
超级查询: 多条件VLookup    多值VLookup  |   跨多个工作表的 VLookup   |   模糊查询 ....
高级下拉列表: 快速创建下拉列表   |  依赖下拉列表   |  多选下拉列表 ....
列管理器: 添加特定数量的列  |  移动列  |  切换隐藏列的可见性状态  |  比较范围和列 ...
特色功能: 网格焦点   |  设计图   |   大方程式酒吧    工作簿和工作表管理器   |  资源库 (自动文本)   |  日期选择器   |  合并工作表   |  加密/解密单元格    按列表发送电子邮件   |  超级筛选   |   特殊过滤器 (过滤粗体/斜体/删除线...)...
前 15 个工具集12 文本 工具 (添加文本, 删除字符,...)   |   50+ 图表 类型 (甘特图,...)   |   40+ 实用 公式 (根据生日计算年龄,...)   |   19 插入 工具 (插入二维码, 从路径插入图片,...)   |   12 转化 工具 (小写金额转大写, 货币兑换,...)   |   7 合并与拆分 工具 (高级组合行, 分裂细胞,...)   |   ... 和更多

使用 Kutools for Excel 增强您的 Excel 技能,体验前所未有的效率。 Kutools for Excel 提供了 300 多种高级功能来提高生产力并节省时间。  单击此处获取您最需要的功能...

kte选项卡201905


Office Tab 为 Office 带来选项卡式界面,让您的工作更加轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,发布者,Access,Visio和Project。
  • 在同一窗口的新选项卡中而不是在新窗口中打开并创建多个文档。
  • 每天将您的工作效率提高50%,并减少数百次鼠标单击!
Comments (7)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
how to count the number of cells other than 0 but not in sequential location, there is a downward gap.
This comment was minimized by the moderator on the site
Hi Yonk,

To calculate the number of non-zero cells across multiple ranges in Excel, you can try the following formula:
Assuming the areas you want to count are B41:C44, F43:F46, and H46:H47, the formula would be:
=COUNTIF(B41:C44, "<>0") + COUNTIF(F43:F46, "<>0") + COUNTIF(H46:H47, "<>0")
This comment was minimized by the moderator on the site
BRILLIANT ..searched 4 hours for this and every other expert gave me the most complicated formuals that never worked.formula: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"),

thx you
This comment was minimized by the moderator on the site
THANK FOR YOUR INFORMATION
This comment was minimized by the moderator on the site
=CONT.SE(AL27:AL31;">0")
This comment was minimized by the moderator on the site
thanks for your efforts
This comment was minimized by the moderator on the site
Q.How to count non zero cell.
Ans. =COUNTIF(F26:Q26,">0")
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations